DO 4.3rc2 var displayTypes = assembly.GetTypes().Where(a => a.GetCustomAttributes(typeof(DisplayTypeAttribute), false).Count() > 0);

Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.
{"Could not load file or assembly 'PostSharp.Public, Version=1.0.0.0, Culture=neutral, PublicKeyToken=b13fd38b8f9c99d7' or one of its dependencies. The system cannot find the file specified.":"PostSharp.Public, Version=1.0.0.0, Culture=neutral, PublicKeyToken=b13fd38b8f9c99d7"}

I have grep'ped our project and found no references to Postsharp v1 there. No referenced libraries except DO use PostSharp. Did you forget to remove a reference?

This thread was imported from our support forum. The original discussion may contain more detailed answer.

asked May 25 '10 at 14:36

xumix's gravatar image

xumix
425757682

We'll check this asap.

(May 25 '10 at 14:36) Dmitri Maximov Dmitri%20Maximov's gravatar image

One Answer:

Just did the same, there are no any references to PostSharp.Public from our assemblies and .csproj files.

So I recommend to turn on Fusion Log to find out the cause. See e.g. this article for details.

answered May 26 '10 at 02:39

Alex%20Yakunin's gravatar image

Alex Yakunin
29714412

Seems, like i've found the problem, some references were ****'ed up with local dll's copied to the 'bin' folder

(May 26 '10 at 02:39) xumix xumix's gravatar image
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!
toggle preview

Subscription:

Once you sign in you will be able to subscribe for any updates here

Tags:

×574

Asked: May 25 '10 at 14:36

Seen: 4,254 times

Last updated: May 25 '10 at 14:36

powered by OSQA