The Extensions (for mass updates/deletes) doesn't work with 4.5. It gives a runtime error saying it needs 4.4 (or was it 4.3?).

Anyway we can get a working version with 4.5 up quickly?

asked Dec 01 '11 at 06:46

ara's gravatar image

ara
395878791


One Answer:

Ara,

First of all, update to the latest DataObjects.Net Extensions package version (1.27 for now). Then update the reference to the assembly according to the following pattern:

{SolutionDir}\packages\DataObjectsExtensions.1.2.7\AllVersions\{Version}

In your case {Version} will be 4.5.0.

I hope Alexander will correct me in case I'm wrong.

answered Dec 01 '11 at 06:56

Dmitri%20Maximov's gravatar image

Dmitri Maximov
22111211

edited Dec 01 '11 at 06:58

1

all right.

(Dec 01 '11 at 07:05) proff proff's gravatar image

Is there a compatibility update for the latest release of 4.5 beta 9? Currently throws an exception: Method not found: 'Xtensive.Sql.Dml.SqlSelect Xtensive.Orm.Providers.Sql.QueryRequest.get_SelectStatement()'.

(Feb 27 '12 at 22:23) ara ara's gravatar image

The Extensions is not yet compatible with DataObjects.Net 4.5 beta 9. We are working on this right now.

(Feb 28 '12 at 02:46) Dmitri Maximov Dmitri%20Maximov's gravatar image
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!
toggle preview

Subscription:

Once you sign in you will be able to subscribe for any updates here

Tags:

×3

Asked: Dec 01 '11 at 06:46

Seen: 2,045 times

Last updated: Feb 28 '12 at 02:46

powered by OSQA