Hi All,

This may be a simple question, but its my first project using this framework and I'm at loss to find an answer myself.

I have data that I want to use within my application right from the start. I've got a table of 5000 entries and another that has 1200 entries. These items will be managed by users, but to save them the trouble, I'd like to have them prepopulated.

Currently I have them in SQL, but after DataObjects setup my SQL structures I inserted them in directly. After running the application again, the data was gone.

The only reference I've found to setting up pre-populated data was by actually using DataObjects to create entities and save them. This is all well and good for smaller lists, but there has to be a better way to deal with this.

Can anyone provide enlightenment?

Cheers,

Kevin

asked Dec 05 '11 at 11:52

twist's gravatar image

twist
29225


One Answer:

Hi twist,

I'm suspecting that you are building domain in DomainUpgradeMode.Recreate, could you check this? In this mode the tables are dropped and created from scratch.

For further information see manual, section "Upgrade mode".

Hope that helps

answered Dec 06 '11 at 06:47

Dmitri%20Maximov's gravatar image

Dmitri Maximov
22111211

I did find this and changed it to "Perform". Does that mean that once the DB has been initialized by DO that you can manually work the data in SQL without issue?

(Dec 06 '11 at 12:37) twist twist's gravatar image
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!
toggle preview

Subscription:

Once you sign in you will be able to subscribe for any updates here

Tags:

×5
×1
×1
×1

Asked: Dec 05 '11 at 11:52

Seen: 1,505 times

Last updated: Dec 06 '11 at 12:37

powered by OSQA