Hi,

We would like to use Telerik Reporting for creation of reports in our application. I guess that in the final product it will work fine but the designer in Visual Studio 2010 causes me a headache.

The designer uses reflection to instantiate the entities of DO and this causes the assembly to run in the context of devenv. It tries to read DO's setting from the devenv.exe.config which is not in there of course.

I can think of 2 solutions:

  • Add the configuration to the devenv.exe.config and copy needed dll's to the directory of devenv.exe (not very nice).

  • Completely configure the settings in code without refering to the app.config.

I've tried the latter but it still seems to need the setting in the app.config at the moment I set the configuration.DefaultSchema.

What can we do?

Regards Paul

asked Mar 13 '13 at 10:25

Paul%20Sinnema's gravatar image

Paul Sinnema
261878896

edited Mar 13 '13 at 10:26

This is an older thread but the problem is still present. Any solutions here?

(Jan 31 '14 at 06:01) Paul Sinnema Paul%20Sinnema's gravatar image

We're not in VS2010 but VS2013 at the moment and are retrying the mentioned approach

(Jan 31 '14 at 06:02) Paul Sinnema Paul%20Sinnema's gravatar image
Be the first one to answer this question!
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!
toggle preview

Subscription:

Once you sign in you will be able to subscribe for any updates here

Tags:

×4

Asked: Mar 13 '13 at 10:25

Seen: 1,816 times

Last updated: Jan 31 '14 at 06:02

powered by OSQA